1. jjacky
  2. kalu
  3. Issues
Issue #12 new

Trying to do a system update freezes Virtualbox

Philip Manjaro
created an issue

I'm one of the core-developers of Manjaro Linux, an archbased distro. We are using kalu as our update-notifier. First, great work mate.

Carl Duff our document-manager just wanted to create a nice tutorial how to use kalu using Virtualbox. As soon as he tries to start the GTK gui VirtualBox freezes showing gksu dialog. You're forced to kill Virtualbox.

This happens every time. I tested it myself on Manjaro 0.8.2rc2 image. To quick-fix this issue I might uninstall kalu from my install-media when Virtualbox gets detected.

Maybe you find some time to try it out yourself using Archlinux or if you want any Manjaro Linux install media.

Comments (4)

  1. jjacky repo owner

    Well, I just tried running kalu and using its system updater in a VM (Arch Linux as both host & guest), worked fine.

    I'm not sure what you mean by the gksu dialog, I'm guessing your polkit agent? kalu doesn't have anything to do with it, it just ask polkit for authentication, and the agent gets triggered by polkit. Do you have the same issue with other app needing auth through polkit? Maybe it's an issue from polkit/the polkit agent?

    Also, not that it's a problem (I need to close things properly here...), but I've actually moved kalu to github (https://github.com/jjk-jacky/kalu), since you got here I'm guessing you might have an old version; maybe try with the latest version of kalu (1.3.0).

    I'll try to do more testing to see if I can reproduce it.

  2. Philip Manjaro reporter

    Well, I'm using kalu 1.3.0 (https://git.manjaro.org/packages-sources/addon/trees/master/kalu) on Manjaro. We are using oder packages from Archlinux. Maybe a new sync will fix this. I just wanted to know it is a general bug or just on my distro.

    To reproduce download any Manjaro 0.8.2rc2 build (http://sourceforge.net/projects/manjarodev/files/testbuild/0.8.2rc2/). Start it up in Virtualbox (we still have VB 4.2.0) and it freezes your Virtualbox programm.

    It simple might be the combination Manjaro 0.8.2rc2 host with Virtualbox 4.2.0. Also it might be possible that Manjaro 0.8.2rc2 works fine on a different host and virtualbox version.

    As soon as you try to start your GTK-gui for system-upgrade it will freeze during authentication.

  3. jjacky repo owner

    One thing you can try, is edit the policy file (/usr/share/polkit-1/actions/org.jjk.kalu.policy) and replace auth_admin with yes

    This will remove the need for identification (password prompt), so if the problem goes away it's probably the polkit agent that's causing this...

  4. Philip Manjaro reporter

    Seems not to be the problem. Authentication dialog now didn't show up since we granted access thru org.jjk.kalu.policy. kalu checked for updates and freezes once more. Last message I can see is: Got package list, Waiting for user confirmation You're forced to kill Virtualbox ...

  5. Log in to comment