Commits

Cody Schafer committed 0700434

things

Comments (0)

Files changed (5)

+# HG changeset patch
+# Parent b9e16b13be3d06ab447a2fb7b576b75fb3a937f3
+diff --git a/config/target.in b/config/target.in
+--- a/config/target.in
++++ b/config/target.in
+@@ -296,6 +296,15 @@
+     prompt "Floating point:"
+     depends on ARCH_SUPPORTS_WITH_FLOAT
+ 
++config ARCH_FLOAT_AUTO
++    bool
++    prompt "auto (let gcc decide)"
++    help
++      Instead of explicitly passing a float option, don't
++      pass any float options and let gcc figure it out.
++
++      For multilib configurations, this may help.
++
+ config ARCH_FLOAT_HW
+     bool
+     prompt "hardware (FPU)"
+@@ -364,6 +373,7 @@
+ config ARCH_FLOAT
+     string
+     default ""       if ! ARCH_SUPPORTS_WITH_FLOAT
++    default "auto"   if ARCH_FLOAT_AUTO
+     default "hard"   if ARCH_FLOAT_HW
+     default "soft"   if ARCH_FLOAT_SW
+     default "softfp" if ARCH_FLOAT_SOFTFP
+# HG changeset patch
+# Parent f9da407127ed79bced5b72673c2d25a6bb8429b7
+diff --git a/scripts/build/cc/gcc.sh b/scripts/build/cc/gcc.sh
+--- a/scripts/build/cc/gcc.sh
++++ b/scripts/build/cc/gcc.sh
+@@ -285,8 +285,9 @@
+         extra_config+=("--with-ppl=${complibs}")
+         # With PPL 0.11+, also pull libpwl if needed
+         if [ "${CT_PPL_NEEDS_LIBPWL}" = "y" ]; then
+-            host_libstdcxx_flags+=("-L${complibs}/lib")
+-            host_libstdcxx_flags+=("-lpwl")
++            #host_libstdcxx_flags+=("-L${complibs}/lib")
++            #host_libstdcxx_flags+=("-lpwl")
++            :
+         fi
+         extra_config+=("--with-cloog=${complibs}")
+     elif [ "${CT_CC_GCC_HAS_GRAPHITE}" = "y" ]; then
+# HG changeset patch
+# Parent 55e4becd7579965e902e068a4264c5a6979236d0
+diff --git a/config/companion_libs/ppl.in b/config/companion_libs/ppl.in
+--- a/config/companion_libs/ppl.in
++++ b/config/companion_libs/ppl.in
+@@ -6,15 +6,9 @@
+ # Don't remove next line
+ # CT_INSERT_VERSION_BELOW
+ 
+-config PPL_V_1_0
+-    bool
+-    prompt "1.0"
+-    select PPL_0_11
+-
+ config PPL_V_0_12_1
+     bool
+     prompt "0.12.1"
+-    select PPL_0_11
+ 
+ config PPL_V_0_11_2
+     bool
+@@ -42,7 +36,6 @@
+     string
+ # Don't remove next line
+ # CT_INSERT_VERSION_STRING_BELOW
+-    default "1.0" if PPL_V_1_0
+     default "0.12.1" if PPL_V_0_12_1
+     default "0.11.2" if PPL_V_0_11_2
+     default "0.11.1" if PPL_V_0_11_1
+# HG changeset patch
+# Parent 7e2d5b6b3aed65bf9a6da9651ca109eb945ae3cb
+diff --git a/config/companion_libs/ppl.in b/config/companion_libs/ppl.in
+--- a/config/companion_libs/ppl.in
++++ b/config/companion_libs/ppl.in
+@@ -54,3 +54,4 @@
+ 
+ config PPL_NEEDS_LIBPWL
+     bool
++    default n
 gdb-7.5.1.diff
 ppl-update
 ppl-patches
+ppl-update2
+ppl-update3
+arch-float-auto
+ppl-pwl-hack