1. Joachim Hofer
  2. eCobertura
  3. Issues
Issue #10 new

Ecobertura can't be installed on Kepler

created an issue

Ecobertura can't be installed on Kepler because the bundle org.junit4 no longer exists in Kepler as it has been renamed to org.junit. To be precise Kepler includes Junit version 4.11.

Comments (5)

  1. James Woods

    It seems that Cobertura has fallen out of maintenance and eCobertura along with it. I have had success with using the new EclEmma plugin instead, which is now based on JaCoCo.

  2. Joachim Hofer repo owner

    Indeed, I'd advise anyone to use JaCoCo/EclEmma instead. Cobertura was out of maintenance for a very long, though there seems to be some recent activity again. I never got any response from the Cobertura people when I asked stuff or tried to contribute there. This was all a few years ago, though. At that time, there was only really Emma or Cobertura for coverage, and EclEmma was based on Emma. - But now there's JaCoCo, which is an active project that's looking great, imho, and EclEmma is based on JaCoCo. So I think any kind of work on an Eclipse coverage plug-in is far better spent by contributing to EclEmma or JaCoCo than here.

  3. Steve Brown

    When I did a review of Java coverage tools in June 2014 looking for coverage tools that worked with Java SE 7 and Google Web Toolkit, I found that GWT instrumented Java bytecode and thus completely broke JaCoCo.

    The only error-free coverage tool for Java SE 7 that I found was Atlassian's Clover tool, but that is a commercial product.

    In January 2015, I use eCobertura on Eclipse Luna SR1. I use the -XX:-UseSplitVerifier Java option to disable the Java SE 7 class verifier (which breaks Cobertura). Note this option has been removed from Java SE 8. You can install eCobertura by copying the junit library from an Eclipse Helios installation to your Eclipse Luna.installation.

  4. Log in to comment