Commits

joseph_leon  committed 5228a21

add jquery update module and settings feature to /modules, added the new feature as a dependency

  • Participants
  • Parent commits 1741b76

Comments (0)

Files changed (5)

 dependencies[] = globalredirect
 dependencies[] = imce
 dependencies[] = inline_messages
+dependencies[] = jquery_update
 dependencies[] = libraries
 dependencies[] = menu_block
 dependencies[] = metatag
 dependencies[] = plato_permissions
 dependencies[] = plato_private_file_system_path
 dependencies[] = plato_user_registration
+dependencies[] = plato_jquery_update

File modules/plato_jquery_update/plato_jquery_update.features.inc

+<?php
+/**
+ * @file
+ * plato_jquery_update.features.inc
+ */
+
+/**
+ * Implements hook_ctools_plugin_api().
+ */
+function plato_jquery_update_ctools_plugin_api($module = NULL, $api = NULL) {
+  if ($module == "strongarm" && $api == "strongarm") {
+    return array("version" => "1");
+  }
+}

File modules/plato_jquery_update/plato_jquery_update.info

+name = Plato jQuery Update
+description = Turns on jQuery Update if not on and sets to 1.7
+core = 7.x
+package = Features
+version = 7.x-1.0
+project = plato_jquery_update
+dependencies[] = ctools
+dependencies[] = strongarm
+features[ctools][] = strongarm:strongarm:1
+features[features_api][] = api:2
+features[variable][] = jquery_update_compression_type
+features[variable][] = jquery_update_jquery_cdn
+features[variable][] = jquery_update_jquery_version

File modules/plato_jquery_update/plato_jquery_update.module

+<?php
+/**
+ * @file
+ * Code for the Plato jQuery Update feature.
+ */
+
+include_once 'plato_jquery_update.features.inc';

File modules/plato_jquery_update/plato_jquery_update.strongarm.inc

+<?php
+/**
+ * @file
+ * plato_jquery_update.strongarm.inc
+ */
+
+/**
+ * Implements hook_strongarm().
+ */
+function plato_jquery_update_strongarm() {
+  $export = array();
+
+  $strongarm = new stdClass();
+  $strongarm->disabled = FALSE; /* Edit this to true to make a default strongarm disabled initially */
+  $strongarm->api_version = 1;
+  $strongarm->name = 'jquery_update_compression_type';
+  $strongarm->value = 'min';
+  $export['jquery_update_compression_type'] = $strongarm;
+
+  $strongarm = new stdClass();
+  $strongarm->disabled = FALSE; /* Edit this to true to make a default strongarm disabled initially */
+  $strongarm->api_version = 1;
+  $strongarm->name = 'jquery_update_jquery_cdn';
+  $strongarm->value = 'none';
+  $export['jquery_update_jquery_cdn'] = $strongarm;
+
+  $strongarm = new stdClass();
+  $strongarm->disabled = FALSE; /* Edit this to true to make a default strongarm disabled initially */
+  $strongarm->api_version = 1;
+  $strongarm->name = 'jquery_update_jquery_version';
+  $strongarm->value = '1.7';
+  $export['jquery_update_jquery_version'] = $strongarm;
+
+  return $export;
+}