Proteus Gerber file won't parse

Issue #153 duplicate
Thomas Ender created an issue

Good evening,

I tried every possible solution to the problem but it seems as if Proteus Gerber files aren't being parsed.

Could you please inform me if it is a bug or if I'm doing something wrong?


Comments (7)

  1. Juan Pablo Caram repo owner

    They work just fine:


    Which version of FlatCAM are you using? Windows, Linux, Mac-OS? Did you get any errors?

  2. Juan Pablo Caram repo owner

    It is possible that this is a problem in version 8.3 and that has been solved in the development version. I will try this on the released 8.3. Any chance you could test the development version?

  3. Thomas Ender reporter

    Do you mean running it from python directly? I tried to find a guide on how to go into the development version and couldn't find any :/

    Thanks for your help though :)

  4. Thomas Ender reporter

    Hello :)

    I tried running the codes in Linux and the development version, giving me a couple of errors while opening files, nominally Error code 4 - Wrong argument something (not at the office right now) but it seems like there's a bug. I'll try running it on another computer though and check in with you again.

  5. Juan Pablo Caram repo owner

    This is the printout in release 8.3:

    $ python 
    [ERROR] PARSING FAILED. Line 32: X-28560Y+30490D02*
    [ERROR][Dummy-1] ArgumentError("argument 4: <type 'exceptions.TypeError'>: wrong type",)
    Line 32: X-28560Y+30490D02*
    [ERROR][Dummy-1] Abnormal termination of process!
    [ERROR][Dummy-1] <class 'camlib.ParseError'>
    [ERROR][Dummy-1] ArgumentError("argument 4: <type 'exceptions.TypeError'>: wrong type",)
    Line 32: X-28560Y+30490D02*
    [ERROR][Dummy-1] <traceback object at 0x7f28a4e62cf8>
    Traceback (most recent call last):
      File "/home/jpcaram/FlatCAM-8.3/", line 32, in do_worker_task
      File "/home/jpcaram/FlatCAM-8.3/", line 1600, in open_gerber
        self.new_object("gerber", name, obj_init)
      File "/home/jpcaram/FlatCAM-8.3/", line 780, in new_object
        initialize(obj, self)
      File "/home/jpcaram/FlatCAM-8.3/", line 1575, in obj_init
        gerber_obj.parse_file(filename, follow=follow)
      File "/home/jpcaram/FlatCAM-8.3/", line 1444, in parse_file
        self.parse_lines(gstr, follow=follow)
      File "/home/jpcaram/FlatCAM-8.3/", line 1947, in parse_lines
        raise ParseError("%s\nLine %d: %s" % (repr(err), line_num, gline))
    camlib.ParseError: ArgumentError("argument 4: <type 'exceptions.TypeError'>: wrong type",)
    Line 32: X-28560Y+30490D02*

    This is related to the '+' sign in the coordinate numbers. Therefore this is a duplicate of #142 which has been solved.

    Please use the latest development version as explained here: or wait for the next release. I hoping to release in the next couple of weeks depending of how I make progress solving other bugs.

  6. Log in to comment