Commits

jpclizbe  committed 2e3fc3b

Add note to common.ml preceding line where a development version is tagged
regarding '-warn-error A' vs '-warn-error a' usage in Makefile.

  • Participants
  • Parent commits f80dd03

Comments (0)

Files changed (1)

 let enforced_filters = ["yminsky.dedup"]
 
 let version_tuple = (__VERSION__)
+(* for Release versions, COMMONCAMLFLAGS in Makefile should include          *)
+(* '-warn-error a'. Development work should use '-warn-error A' for stricter *)
+(* language checking. This affects the Ocaml compiler beginning with v4.01.0 *)
 let version_suffix = "+" (* + for development branch *)
 let compatible_version_tuple = (0,1,5)
 let version =