Issue #12 resolved
created an issue

further to my comment on the addon page. I had it running previously in fx7 which I d been using on a different machine. Just updated my notebook and tried to install it on fx8 however, while it said it was installed&active in the addon menu, i was unable to find it in either tools or web developer. So I tried another s fix by uninstalling fx8, reinstalling fx9 then reinstalling cacheveiwer which didnt seem to fix the problem either. While it is present in my addon/ extension page it is not shown anywhere. Dont know what else to tell you, ask and i shall answer. Thanks for the help, if the problem appears abit of a stretch don't worry bout it and i'll survive

Comments (12)

  1. Anonymous

    (addition to comment #1:) found a trick: right click on the menu tollbar and select customize. then add the "cache viewer" icon to the toolbar you like (menue is the one I used).

    So it seems that the item is just not been added to the toolbar/menu correctly.

    BTW how could I just create an account here for comments only?)

  2. James Sumners repo owner
    • changed status to open

    Hmm, this code was added in changeset 67f05a8c2116. I wonder if your browser didn't have the elements referenced in the "insertbefore" attributes. I had to really dig down into Firefox's source code to even find those element names because the actual documentation is awful. But that's the only way to insert into the developer menu and have the insert occur as the last item. Being the last item should make it easier to find on new installations.

    I'm open to suggestions on how to fix this.

    @anonymous: the site supports several OpenID providers. You can use one of those if you have an account with one.

  3. Sergey Ushakov

    Hi, no ideas on fixing, just a confirmation that I have this issue too with my OS X 10.7, FF 11.0 and CacheViewer Continued 0.7.

    The trick from comment #2 did the job for me though.

  4. James Sumners repo owner

    I believe this issue happens when a user has the original CacheViewer installed prior to installing CacheViewer Continued. I don't have time to test this theory right now, so I'm leaving the bug open for now.

  5. Anonymous

    If you do not find the "CacheViewer"-Menu in the "Tools"-Menu, try in "Tools - Web Developpers". You will find it there.

  6. vanclute

    EDIT: It actually DOES work, I didn't realize it was already in the add-on bar, and the little tiny magnifying icon was almost too small to see on my 30" display.

    I not only don't get a menu item, but it does not appear in my list of available add-on toolbar extensions. I seem to have no way to invoke it at all. The shortcut doesn't work either. I have uninstalled, restarted Firefox, and reinstalled, then restarted. No change. Any suggestions? Firefox 19.0 Mac.

  7. vanclute

    I have to amend my previous edit that stated the add-on worked. It works ONLY as a viewer, I can no longer save files out of the cache. Is this intentional? Is this strictly a viewer now?

  8. Log in to comment