mysql_stmt_execute error: *Out of range value for column 'retained' at row 1

Issue #813 closed
Mark Clarke created an issue

Hi Jutso,

I have just upgraded from 1.1.1 to 1,2.0. I applied the update script to the database "mysql -u piler -p piler < util/db-upgrade-1.1.0-vs-1.2.0.sql". When I ran this command there was no output but the processes exited after several minutes without any output. I assume it ran successfully.

Everything looks fine. I copied over the new webui and the config files. I can login via imap with ssl, which was broken in 1.1.1 with PHP7.0 but is working with 1.2.0

Checking the log file (mail.log) to see if new mails where being imported correctly I observed the following errors on new mails:

"mysql_stmt_execute error: Out of range value for column 'retained' at row 1 (errno: 1264)"

The exact version is: 1.2.0 build 952

From what I can tell the column retained is in the metadata table and is int(10) unsigned. I had a look at the sql update script but it doesn't seem to have any reference to the metadata table except for the creation of a view which references it.

Should I just do an alter table and change the data type to big int? The current max(retained) is 1659160705.

Comments (4)

  1. Mark Clarke reporter

    I ran "alter table metadata modify retained bigint;" It ran for about an hour. All seems good so far.

  2. Log in to comment