Can't expand Open File Dialog

Issue #1 resolved
Former user created an issue

I just downloaded the latest listed version, and I cannot expand the small File Open dialog. It has a symbol on the lower right corner that appears to indicate it should be enlargeable, but I can't seem to click and actually enlarge it. Should this work, or is this a known issue, or... ?

Version 0.2011.001.497

(Changing default major priority to minor)

Comments (2)

  1. Anonymous

    Downloaded source. Tried debugging.

    I see call through

    LRESULT CFloatState::CallWindowProc(WNDPROC pfnSuper, HWND hWnd, UINT uMsg, WPARAM wParam, LPARAM lParam)

    to

    CFloatState::AdjustHit

    which falls into this following case and set the hit test to HTNOWHERE

    case HTTOPLEFT: case HTTOPRIGHT: case HTBOTTOMLEFT: case HTBOTTOMRIGHT: if ((flags & 0x00FF00FF) == 0 || (flags & 0xFF00FF00) == 0) uHitTest = HTNOWHERE;

    So it looks like it is just the corners that are broken. I noticed that the sides actually work for resizing.

    It is unfortunate (and humorous) that the resizing icon is actually in the corner, which is the one place that it is broken.

    The fix might as simple as changing that logical or to a logical and. I tried that fix, and it works.

  2. Log in to comment