Issue #18 new
Ray Lance
created an issue

Installing with R14A required changing the rebar.config to 1.7.1 and in /tmp/mywebdemo to 1.7.

Perhaps this should be mentioned in the quickstart, or better yet, obviated somehow in the code?

Comments (1)

  1. Anonymous

    Needed to do this even with 13B04 i.e. set to mochiweb version to 1.7.1 ...

    Also creating a new webmachine works ... but then running make in the new webmachine directory, fails because it's looking for webmachine version 1.6 in rebar.config (if I'm reading it correctly). This is using the current tip of webmachine from the repository and running make on that (which throws the 1.7.0 error which is then fixed by changing to 1.7.1) before running the new_webmachine script.

    cave:webmachine root# scripts/new_webmachine.sh testingwm /opt

    > priv (create)

    Writing /opt/testingwm/README Writing /opt/testingwm/Makefile Writing /opt/testingwm/rebar.config Writing /opt/testingwm/rebar Writing /opt/testingwm/start.sh Writing /opt/testingwm/ebin/testingwm.app Writing /opt/testingwm/src/testingwm.erl Writing /opt/testingwm/src/testingwm_app.erl Writing /opt/testingwm/src/testingwm_sup.erl Writing /opt/testingwm/src/testingwm_resource.erl Writing /opt/testingwm/priv/dispatch.conf

    cave:testingwm root# make

    > testingwm (get-deps)

    Pulling webmachine from {hg,"http://bitbucket.org/basho/webmachine","tip"} requesting all changes adding changesets adding manifests adding file changes added 162 changesets with 438 changes to 172 files 96 files updated, 0 files merged, 0 files removed, 0 files unresolved ERROR: Dependency dir /opt/testingwm/deps/webmachine does not satisfy version regex 1.6.

  2. Log in to comment