Issue #1 resolved

Can not use newer version lib,pls help to solve it, thx

Anonymous created an issue

kuruwamatoMacBook-Air:Downloads admin$ cd erlymud kuruwamatoMacBook-Air:erlymud admin$ ./rebar compile ==> erlymud (compile) Compiled src/em_user_sup.erl Compiled src/em_user.erl Compiled src/em_util_sha2.erl Compiled src/em_sup.erl Compiled src/em_session_sup.erl Compiled src/em_session.erl Compiled src/em_room_sup.erl Compiled src/em_room_pool_sup.erl Compiled src/em_text.erl Compiled src/em_telnet.erl Compiled src/em_room_mgr.erl Compiled src/em_rh_login.erl Compiled src/em_req_sup.erl Compiled src/em_req.erl Compiled src/em_room.erl Compiled src/em_living_sup.erl Compiled src/em_rh_game.erl Compiled src/em_listener.erl Compiled src/em_object.erl Compiled src/em_grammar.erl Compiled src/em_conn_sup.erl Compiled src/em_living.erl Compiled src/em_game.erl Compiled src/em_app.erl Compiled src/em_acceptor_pool.erl Compiled src/em_acceptor_sup.erl Compiled src/em_conn.erl Compiled src/em_acceptor.erl ==> erlymud (compile) kuruwamatoMacBook-Air:erlymud admin$ sudo erl -pa lib/erlymud/ebin/ Erlang R15B (erts-5.9) [source] [smp:4:4] [async-threads:0] [hipe] [kernel-poll:false]

Eshell V5.9 (abort with ^G) 1> systools:make_script("erlymud-0.3.3", [local]). sasl: No valid version ("2.1.9.2") of .app file found. Found file "/usr/local/lib/erlang/lib/sasl-2.2/ebin/sasl.app" with version "2.2"

stdlib: No valid version ("1.17.2") of .app file found. Found file "/usr/local/lib/erlang/lib/stdlib-1.18/ebin/stdlib.app" with version "1.18"

kernel: No valid version ("2.14.2") of .app file found. Found file "/usr/local/lib/erlang/lib/kernel-2.15/ebin/kernel.app" with version "2.15"

error 2> User switch command --> q kuruwamatoMacBook-Air:erlymud admin$

Comments (3)

  1. Anonymous

    After I changed the erlymud-0.3.3.rel, It is ok, thanks . ^^

    Your code is the first Erlang code I will study.

  2. Log in to comment