Commits

Jakub Wilk committed 9ca0da4

Issue only a warning with Python 3.0 or 3.1.

Comments (0)

Files changed (1)

 sys.path[:0] = [sys_path0]
 
 if sys.version_info >= (3, 0) and sys.version_info < (3, 2):
-
-    raise NotImplementedError
+    import warnings
+    class NotImplementedWarning(Warning, NotImplementedError):
+        pass
+    warnings.warn('Python %d.%d is not supported' % sys.version_info[:2], category=NotImplementedWarning, stacklevel=2)
 
 if sys.version_info < (2, 7):