Source

django-fitlog / INSTALL

Full commit
Requirements
------------
* Django 1.5 or newer
* Django sessions need to be enabled
* Django south 0.7 or newer for migrations
* django pagination

------------
Installation
------------

`pip install hg+https://bitbucket.org/kencochrane`

--------
Settings
--------

App
===
Add the following to your INSTALLED_APPS:

```
INSTALLED_APPS = [
    ...
    'fitlog',
    'south',
    'pagination',
]
```

Add the following TEMPLATE_CONTEXT_PROCESSORS:

```
TEMPLATE_CONTEXT_PROCESSORS = (
    "django.contrib.auth.context_processors.auth",
    "django.core.context_processors.debug",
    "django.core.context_processors.i18n",
    "django.core.context_processors.media",
    "django.core.context_processors.request")
```

Add the following middleware:

```
MIDDLEWARE_CLASSES = (
    ...
    'pagination.middleware.PaginationMiddleware',
)
```

Sync Tables
===========
Run ./manage.py syncdb to load up the tables in your database.
run ./manage.py migrate to run the south migrations