1. Oliver Smith
  2. tradedangerous
  3. Issues
Issue #269 new

INTERNAL ERROR while Rebuilding cache

Steve Thornton
created an issue

I have just installed Python 3.6. Downloaded TradeDangerous from this website. Copied all the data files from Maddavo's web site. Executed the first example command shown on the Overview and get an error. I have tried other commands and get the same error. I am unable to get any further.

I hope you can help me.

This is a copy of my CMD screen:

Microsoft Windows [Version 10.0.14393] (c) 2016 Microsoft Corporation. All rights reserved.

C:\Users\Steve>e:

E:>cd ed\td

E:\ED\TD>trade.py ru --fr=and/kumm --cr=5k --cap=8 --ly=8.56 --ju=2

NOTE: Rebuilding cache file: this may take a few moments.

*** INTERNAL ERROR: table Station has no column named planetary CSV File: E:\ED\TD\data\Station.csv:2 SQL Query: INSERT INTO Station (system_id,name,ls_from_star,blackmarket,max_pad_size,market,shipyard,modified,outfitting,rearm,refuel,repair,planetary) VALUES((SELECT System.system_id FROM System WHERE System.name = ?),?,?,?,?,?,?,?,?,?,?,?,?) Params: ['1 G. CAELI', 'Yize Camp', '3490', 'N', '?', 'N', 'N', '2016-11-26 20:45:06', 'N', 'N', 'N', 'N', 'Y']

E:\ED\TD>

Comments (3)

  1. Log in to comment