invoking a Menu Item called "Solid" gives an error that it wasn't found

Create issue
Issue #89 on hold
Jeff Almasol created an issue
  1. open KBar Settings
  2. click Add Button > Invoke Menu Item
  3. search for "solid" (no quotes), then select the bottom result called "Solid" (not the one with ellipsis). click OK.
  4. open a comp, then click this "Solid" menu item button.

--> script alert: Could not run menu item "Solid" Perhaps there was a typo?. Error: Command Id for "Solid" was not found.

do you know what this "Solid" menu item is for and why it couldn't be invoked? i also tried selecting a layer first, but that didn't seem to help. hmm.

Comments (3)

  1. Rafi Khan

    Ah. So I learned this very late but the list of menu commands that I got came from David Torno's command ID pdf. Since then I learned 2 things...

    1. The menu item list varies by each version of AE (which seems super obvious now but I didn't contemplate that into the list).
    2. The current state of AE dictates whether or not a command item is valid.

    The first item is a pain in the ass to manage/maintain and the second I can't control or hook into. Not sure how to resolve this issue sensibly.

    Suggestions?

  2. Jeff Almasol reporter

    yeah, a tough one... maybe the search results would show the mapping of id <n> = menu command "..." to at least let the user know what you have hardcoded, then just deal with user reports as needed? i know, not ideal.

    for years i tried to steer script authors away from relying on these undocumented calls or ids, but i understand the need for cross-languages support and other functionality that can't be called via menu name. it's like a cold beverage on a hot summer day or a bowl of salted peanuts -- you can't just stop once at one. ;-) i get it. it would be nice if command invocation was easier, so script authors don't have to do crazy things just to get AE into the right state just to invoke a menu command.

  3. Log in to comment