Error: Argument of \write has an extra }.

Create issue
Issue #2 resolved
Former user created an issue

Hallo,

I get the error message Argument of \write has an extra }.

I use the example

\getmap{Bergheimer Straße 110A, 69115 Heidelberg, Germany}
\includegraphics[width=9cm]{getmap}

I also add the argument -shell-escape.

What could be the mistake?

Comments (7)

  1. Josef Kleber repo owner

    I get a different error message, but I can reproduce the problem with TeXLive2018. What Tex distribution are you using?

    I haven't changed getmap for quite a while, but I have read that script handling was changed in TL2018. I have reported the problem to the TL devel list (https://tug.org/pipermail/tex-live/2018-June/041997.html).

    So for the moment, let's wait and see.

    Josef

  2. rob987 NA

    I use ubuntu 16.04 with textlive. I compile my files with docker and use the blang/latex:ubuntu image.

    Thank you for your very fast answer. Yes, let's see.

  3. Josef Kleber repo owner

    Oh, Ubuntu 16.04 would be quite old, but as you are using a docker container there should be a newer one.

    If I understand https://hub.docker.com/r/blang/latex/ correctly, can you please run latexdockercmd.sh pdflatex -v and/or latexdockercmd.sh lualatex -v to get the TeXLive version you are running.

  4. rob987 NA

    Hallo,

    I tested it with TeX Live 2015 with Ubuntu 16.04 and Ubuntu 18.04 with TeX Live 2017 and both give the same error. I used the docker image from here: https://hub.docker.com/r/teukop/latex/.

    With which TeXLive version does getmap work? I could create a docker image with the working TeX Live version.

    Maybe you should use docker to test getmap for each latest commit too.

  5. Josef Kleber repo owner

    getmap does work with all version of TL that provide a working luatex. There's no bug in getmap but in luatex v1.07. It is unable to load the socket.url module, which is needed by getmap The bug was introduced somewhere between v1.0 and v1.07. It worked for sure for version v0.85, because getmap needed some adjustments for this version.

    Adding another abstraction layer with a docker container doesn't make sense, as I am working with up-to-date vanilla TeXLive.

    I have a work-a-round but no clue how you can insert it into your docker container. Replace getmapdl.lua in /texmf-dist/scripts/getmap with this one!

    Hopefully, the problem will be fixed soon upstream.

  6. Josef Kleber repo owner

    After some lengthy discussions, I put a workaround fix version on CTAN, as there's only a fix in the Window's version of luatex v1.0.7 and fixes for other platforms are far. The new version should be in TeXLive and MikTeX within the next days.

  7. Log in to comment