Alakazam with older R version

Issue #41 resolved
psathyrella
created an issue

I wonder if it would be possible for alakazam to require a somewhat lower version of R than 3.1.2. For instance, the current Ubuntu LTS has 3.0.2, which would make dockerizing things much easier.

thanks

Comments (3)

  1. Jason Vander Heiden

    The problem is the dependencies. Alakazam itself should work fine with R>=3.0, if you change the dependency version in the DESCRIPTION fine. However, both the current release of ggplot2 and dplyr require R>=3.1, so if you try to install via CRAN you'll get the "dplyr is not available for R 3.0.2" message, and then have to dig through the CRAN archived releases to find which version, if any, of dplyr and ggplot2-2.X will build on R 3.0.2.

    If this is a system you have control over, my suggestions would be to add the CRAN Ubuntu builds to your apt sources:
    https://cran.r-project.org/bin/linux/ubuntu

    And use that to update R to a current release... R 3.0.2 is creeping up on 3 years old at this point anyway.

  2. Log in to comment