changing tmp directory buildPhylipLineage

Issue #67 resolved
Scott Christley created an issue

I don't have write access to the normal /tmp directory on this system, so I changed TMPDIR in the environment before running R.

export TMPDIR=.

I then walk through the example in the docs for lineage reconstruction, but I get this error. I can see that it does create a temporary directory Rtmp5ZXe31 in the current directory, but not sure what file it is complaining about.

> graph <- buildPhylipLineage(clone, dnapars_exec, rm_temp=TRUE)
Error in runPhylip(temp_path, dnapars_exec, verbose = verbose) : 
  (list) object cannot be coerced to type 'double'
In addition: Warning message:
In file(con, "w") :
  cannot open file './Rtmp5ZXe31/fileb6e1c2d7061': No such file or directory

Or maybe actually the error is with the example data...

Comments (2)

  1. Jason Vander Heiden

    I had the same error using TMPDIR=.. Try an absolute path (eg TMPDIR=/home/user/tmp). That worked for me. It's probably some oddity in how scan interprets relative file paths.

  2. Log in to comment