Issue #314 new

2.1.0b5 - TypeError: Cannot set property 'id' of undefined

John Tapsell
created an issue

I have placed a static non-twine html file "startingpage.html" in the Documents/Twine/Stories folder. It has nothing to do with Twine, and in Twine 2.0 it's been absolutely fine.

But when I launch the new Twine 2.1.0b5 beta, I immediately get:

TypeError: Cannot set property 'id' of undefined at IMPORT_STORY (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:41:19603) at i.(anonymous function) (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:91:5845) at r.value (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:91:4841) at dispatch (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:91:4102) at importStory (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:9:25334) at chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:48:10972 at chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:48:10861 at Object.loadAll (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:48:11018) at chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:60:31781 at Object.init (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:61:11)

At a guess, I moved the static html file out of the way, and that resolved the problem.

Comments (13)

  1. Chris Klimas repo owner

    Are you comfortable uploading this file?

    If not, could you do a quick text search to see if it contains <tw-storydata> or <tw-passage> anywhere in it? The reason I ask is I tried saving the Google home page's HTML into the Stories folder as an experiment, and I don't get an error message, so I am wondering if there's something specific about this file that's throwing off Twine.

  2. Ferry Bryan Joseph

    This happened to me as well while working on a Twine file. I still don't know why the specific file does not work like the other twine files, after sending it to a different document location which led to the others working fine in both the recent beta and the original twine program, but I assume it was a large file that got corrupted.

  3. Anonymous

    Same error message after trying to open Twine after download, see Screenshot. Working on MacOS 10.12.2

    twine bug.png

  4. Haden245

    https://drive.google.com/open?id=0B8W3xSMCYjX6c0ltNUoxd2xzX28

    Here's my faulty file. I've spent quite some time on this, plus it's an assignment for my Uni Game Writing course.

    Here's the error message: 2017-03-20.png

    If anyone can help me fix this, I would be ever so grateful.

    Running a Windows 10 on an ASUS Republic of Gamers Model. I blue screened and crashed while working on my story before the file became bugged. Tried to start up again to continue and the error popped.

    Sincerely, Haden

  5. Haden245

    I was using Twine 2.1.1 I only started this project about 2 weeks ago. So, nah, no back-up but I am backing up now.

    Installed the 32-bit version, and I was using Harlowe 1.2.3

  6. Log in to comment