Getting weird error when trying to open preferences editor

Issue #8 new
Anonymous created an issue

This is the error

Traceback (most recent call last): File "/opt/sublime_text_3/sublime_plugin.py", line 551, in run_ return self.run(**args) File "Preferences Editor in /home/abraham/.config/sublime-text-3/Installed Packages/Preferences Editor.sublime-package", line 876, in run KeyError: 'PHP'

I am not able to debug this because the .sublime-package is binary, any help would be apreciated

Comments (3)

  1. Mike Cramer

    I get this error whenever I try to invoke the "current syntax" item from the command palette when a syntax specific preference file does not yet exist.

    If I choose to open the Syntax specific preference, and save the empty file, and run the "Current Syntax" item again, I can use the plugin without issue.

  2. mrelusive NA

    I ran into the same KeyError, except with Python. Mike Cramer's workaround fixed the issue for me, but I would prefer to not have to create an empty preference file for every syntax I deal with.

    Just a note, I'm currently running Sublime3 on Linux. I don't recall this ever happening on my Windows install of Sublime3, although I haven't confirmed that on a fresh install.

  3. Log in to comment