Unable to open files inside zip archive due to malformed directory path to temporary file

Issue #3 new
Kim Lindblom
created an issue

I'm using Sublime Text 3 on Windows 7.

The zip browser correctly lists the file in my zip archives, but when attempting to open the individual files inside they either appear empty (if text) or says "failed to load image" (if image)

If I add something to the empty file and try to save it back to the zip archive, I get this error message:

Unable to save C:\c:\users\username\appdata\local\temp\Zip Browser\3ac914471290ac358b54599c0a2d1ecb\test\test1.txt Error: MoveFileEx(C:.subl823.tmp, C:\c:\users\username\appdata\local\temp\Zip Browser\3ac914471290ac358b54599c0a2d1ecb\test\test1.txt) failed, The filename, directory name, or volume label syntax is incorrect

I noticed that the error message's path is a little screwed up, so I tried navigating my explorer to the correct path, and I did actually find the unzipped version of the file I was trying to open there. The bug is probably the file path syntax being messed up by the C:\c:\ repetition.

I tried with zip archives created by 7zip and Windows 7's internal zipping mechanism, both produced the same result.

Comments (1)

  1. artemisart

    Exactly the same problem here, actually it seems to prepend the path to the working directory before the path to the temp file when trying to open a file.
    Example :
    file to open : "Zip Browser.sublime-package/README.rst"
    file extracted : "%tmp%/Zip Browser/5a0cfe98f80ac1cdf8f31f228181fe5b/README.rst"
    and it try to open : "./C:/Users/Me/AppData/Local/Temp/Zip Browser/5a0cfe98f80ac1cdf8f31f228181fe5b/README.rst" where "." is the current folder in the project.

  2. Log in to comment