"File write Failed" Error on calibration commit

Issue #14 new
Former user created an issue


0.0.10 (2016-07-12)

Steps to reproduce

  • run ROS kinetic on Ubuntu 16.04 in a Virtual Box.
  • Use the UEye-node to publish the raw images (remapped raw_image and service or not)
  • Then start the camera_calibration node and do the calibration until calibrate button activates.
  • (Saving the Output to /tmp/calibrationdata.tar.gz' works fine.)
  • pressing the commit-button will throw the error.


ueye terminal

calibration terminal

  • ...
  • projection
  • 2699.117188 0.000000 438.453852 0.000000
  • 0.000000 2872.525879 195.136327 0.000000
  • 0.000000 0.000000 1.000000 0.000000
  • !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  • ...
  • !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  • ()
  • Attempt to set camera info failed: file write failed
  • ()
  • !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  • ...
  • !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  • ()
  • [ERROR] [1520405526.986135]: Unable to set camera info for calibration. Failure message: file write failed

Comments (4)

  1. cherry

    Hello, I installed the ueye driver today. According to the instructions on the wiki, after running rosrun ueye stereo, you can see that the camera has started to collect, and there is also a news release, but the rviz tool displays no images received, and the rqt tool does not Display image; rosrun image_view will be stuck when viewing a camera image alone, no image will appear!issue.jpgissues-2.jpg

  2. Kevin Hallenbeck repo owner

    @hi_coder please create a new issue because your problem is separate from this "Error on calibration commit" issue.

    Do your cameras work individually with rosrun ueye camera? Do your cameras work with the other ueye_cam ROS driver?

  3. Ashish Roongta

    Hi Kevin,

    I am facing the same error.ueye_1.png I tried the config_path parameter and used to set to a directory with write access but no good. Also, I am able to commit the calibration when calibrating my webcam and another usb_cam, but am unable to commit the ids camera that I running through the ueye camera node. Could you please help me with this. Thank you

  4. Log in to comment