Mikhail Korobov avatar Mikhail Korobov committed 7d4f1cb

bump version

Comments (0)

Files changed (5)

-Copyright (c) 2010-2011, Mikhail Korobov
+Copyright (c) 2010-2012, Mikhail Korobov
 All rights reserved.
 
 Redistribution and use in source and binary forms, with or without
 CHANGES
 =======
 
+0.7.4 (2012-03-01)
+------------------
+- django-fab-deploy now is compatible with fabric 1.4 (and require fabric 1.4);
+- nginx and wsgi scripts are now compatible with upcoming django 1.4;
+  example of django 1.4 project configuration is added to guide;
+- shortcut for passing env defaults in ``define_host`` decorator;
+- Ubuntu 10.04 apache restarting fix;
+- config_templates/hgrc is removed;
+- tests are updated for fabtest >= 0.1;
+- ``apache_is_running`` function.
+
+In order to upgrade install fabric >= 1.4 and make sure your custom scripts
+work.
+
 0.7.3 (2011-10-13)
 ------------------
 
 
 # General information about the project.
 project = u'django-fab-deploy'
-copyright = u'2011, Mikhail Korobov'
+copyright = u'2010-2012, Mikhail Korobov'
 
 # The version info for the project you're documenting, acts as replacement for
 # |version| and |release|, also used in various other places throughout the
 # The short X.Y version.
 version = '0.7'
 # The full version, including alpha/beta/rc tags.
-release = '0.7.3'
+release = '0.7.4'
 
 # The language for content autogenerated by Sphinx. Refer to documentation
 # for a list of supported languages.
 epub_title = u'django-fab-deploy'
 epub_author = u'Mikhail Korobov'
 epub_publisher = u'Mikhail Korobov'
-epub_copyright = u'2011, Mikhail Korobov'
+epub_copyright = u'2012, Mikhail Korobov'
 
 # The language of the text. It defaults to the language option
 # or en if the language is not set.
-django-fab-deploy == 0.7.1
 jinja2
 fabric >= 1.4.0
     # do not skip git files
     sys.argv.insert(sys.argv.index('sdist') + 1, '--no-prune')
 
-version='0.7.3'
+version='0.7.4'
 
 setup(
     name='django-fab-deploy',
     description = """ Django deployment tool """,
 
     long_description = open('README.rst').read() + open('docs/CHANGES.rst').read(),
-    requires = ['Fabric (>=1.0.0)', 'jinja2'],
+    requires = ['Fabric (>=1.4.0)', 'jinja2'],
 
     classifiers=(
         'Development Status :: 4 - Beta',
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.