Commits

Mikhail Korobov committed 8022282

django 1.4 - compatible apache wsgi script ...kinda

Comments (0)

Files changed (1)

fab_deploy/config_templates/django_wsgi.py

      os.path.normpath('{{ ENV_DIR }}/lib/python2.6/site-packages'),
      os.path.normpath('{{ ENV_DIR }}/lib/python2.7/site-packages'),
 
-     os.path.normpath('{{ PROJECT_DIR }}' + '/..'),
+     os.path.normpath('{{ PROJECT_DIR }}' + '/..'), # <- remove this line if django >= 1.4
      '{{ PROJECT_DIR }}',
 ])
 
+# django < 1.4 wsgi setup
 os.environ['DJANGO_SETTINGS_MODULE'] = 'settings'
-
-#print sys.path
-
 import django.core.handlers.wsgi
 application = django.core.handlers.wsgi.WSGIHandler()
+
+# django >= 1.4 wsgi setup: remove "<1.4 wsgi setup" above, uncomment the
+# following line and set proper your project's name:
+
+# from my_project.wsgi import appliation