Commits

Mikhail Korobov committed 78cf8c8 Merge

Merge pull request #19 from djm/patch-1

Test against Django 1.4.6 & 1.5.2 (updated from 1.4.5 & 1.5.1)

  • Participants
  • Parent commits 3de5ac1, 747eeb7

Comments (0)

Files changed (1)

   - "pypy"
 
 env:
-  - DJANGO_VERSION=1.2.7
-  - DJANGO_VERSION=1.3.7
-  - DJANGO_VERSION=1.4.5
-  - DJANGO_VERSION=1.5.1
+  - DJANGO=">= 1.2, < 1.3"
+  - DJANGO=">= 1.3, < 1.4"
+  - DJANGO=">= 1.4, < 1.5"
+  - DJANGO=">= 1.5, < 1.6"
+  - DJANGO=""
 
 matrix:
     include:
         - python: "2.7"
-          env: DJANGO_VERSION=1.5.1 OLD_WEBTEST=1
+          env: DJANGO=">= 1.5, < 1.6" OLD_WEBTEST=1
     exclude:
         - python: "3.2"
-          env: DJANGO_VERSION=1.2.7
+          env: DJANGO=">= 1.2, < 1.3"
         - python: "3.2"
-          env: DJANGO_VERSION=1.3.7
+          env: DJANGO=">= 1.3, < 1.4"
         - python: "3.2"
-          env: DJANGO_VERSION=1.4.5
+          env: DJANGO=">= 1.4, < 1.5"
         - python: "3.3"
-          env: DJANGO_VERSION=1.2.7
+          env: DJANGO=">= 1.2, < 1.3"
         - python: "3.3"
-          env: DJANGO_VERSION=1.3.7
+          env: DJANGO=">= 1.3, < 1.4"
         - python: "3.3"
-          env: DJANGO_VERSION=1.4.5
+          env: DJANGO=">= 1.4, < 1.5"
         - python: "pypy"
-          env: DJANGO_VERSION=1.2.7
+          env: DJANGO=">= 1.2, < 1.3"
         - python: "pypy"
-          env: DJANGO_VERSION=1.3.7
+          env: DJANGO=">= 1.3, < 1.4"
 
 
 # command to install dependencies, e.g. pip install -r requirements.txt --use-mirrors
 install:
-  - pip install django==$DJANGO_VERSION
+  - pip install "django $DJANGO"
   - if [[ $OLD_WEBTEST ]]; then pip install 'WebTest < 2.0'; else pip install WebTest; fi
   - python setup.py install