Commits

Kirill Krasnov committed 65d15d3

Reorganize first group - keywords

  • Participants
  • Parent commits dcc8c0f

Comments (0)

Files changed (1)

 	'NUMBERS' =>
 		GESHI_NUMBER_INT_BASIC | GESHI_NUMBER_FLT_SCI_ZERO,
 	'KEYWORDS' => array(
-		1 => array('Если', 'If', 'Тогда', 'Then', 'ИначеЕсли', 'ElseIf', 'Иначе', 'Else',
-					'КонецЕсли', 'EndIf', 'Для', 'For', 'Каждого', 'Each', 'Из', 'In', 'По',
-					'To', 'Пока', 'While', 'Цикл', 'Do', 'КонецЦикла', 'EndDo', 'Процедура',
-					'Procedure', 'Функция', 'Function', 'КонецПроцедуры', 'EndProcedure',
-					'КонецФункции', 'EndFunction', 'Перем', 'Var', 'Перейти', 'Goto', 'Возврат',
-					'Return', 'Продолжить', 'Continue', 'Прервать', 'Break', 'И', 'And', 'или',
-					'Or', 'Не', 'Not', 'Попытка', 'Try', 'Исключение', 'Except',
-					'ВызватьИсключение', 'Raise', 'КонецПопытки', 'EndTry', 'Новый', 'New',
-					'Экспорт', 'Export', 'Истина', 'True', 'Ложь', 'False'),
-		2 => array('ВРег', 'КодСимвола', 'Лев', 'Найти', 'НРег', 'Прав',
+		1 => array('если','Если', 'ЕСЛИ', 'If','тогда', 'Тогда', 'ТОГДА', 'Then', 'иначеесли',
+					'ИначеЕсли', 'Иначеесли', 'ИНАЧЕЕСЛИ', 'ElseIf', 'иначе', 'Иначе', 'ИНАЧЕ', 'Else',
+					'конецесли', 'КонецЕсли', 'Конецесли', 'КОНЕЦЕСЛИ', 'EndIf', 'для', 'Для', 'ДЛЯ',
+					'For', 'каждого', 'Каждого', 'КАЖДОГО', 'Each', 'из', 'Из', 'ИЗ', 'In', 'по', 'По',
+					'ПО', 'To', 'пока', 'Пока', 'ПОКА', 'While', 'цикл', 'Цикл', 'ЦИКЛ', 'Do',
+					'конеццикла', 'КонецЦикла', 'Конеццикла', 'КОНЕЦЦИКЛА', 'EndDo', 'процедура',
+					'Процедура', 'ПРОЦЕДУРА', 'Procedure', 'функция', 'Функция', 'ФУНКЦИЯ', 'Function',
+					'конецпроцедуры', 'КонецПроцедуры', 'Конецпроцедуры', 'КОНЕЦПРОЦЕДУРЫ', 'EndProcedure',
+					'конецфункции', 'КонецФункции', 'Конецфункции', 'КОНЕЦФУНКЦИИ', 'EndFunction', 'перем',
+					'Перем', 'ПЕРЕМ', 'Var', 'перейти', 'Перейти', 'ПЕРЕЙТИ', 'Goto', 'возврат', 'Возврат',
+					'ВОЗВРАТ', 'Return', 'продолжить', 'Продолжить', 'ПРОДОЛЖИТЬ', 'Continue', 'прервать',
+					'Прервать', 'ПРЕРВАТЬ', 'Break', 'и', 'И', 'And', 'или', 'Или', 'ИЛИ', 'Or', 'не',
+					'Не', 'НЕ', 'Not', 'попытка', 'Попытка', 'ПОПЫТКА', 'Try', 'исключение', 'Исключение',
+					'ИСКЛЮЧЕНИЕ', 'Except', 'вызватьисключение', 'ВызватьИсключение', 'Вызватьисключение',
+					'ВЫЗВАТЬИСКЛЮЧЕНИЕ', 'Raise', 'конецпопытки', 'КонецПопытки', 'Конецпопытки',
+					'КОНЕЦПОПЫТКИ', 'EndTry', 'экспорт', 'Экспорт', 'ЭКСПОРТ', 'Export',
+		),
+		2 => array('Новый', 'New', 'Истина', 'True', 'Ложь', 'False', 'ВРег', 'КодСимвола', 'Лев', 'Найти', 'НРег', 'Прав',
 					'ПустаяСтрока', 'Символ', 'СокрЛ', 'СокрП', 'СокрЛП',
 					'Сред', 'СтрДлина', 'СтрЗаменить',  'СтрПолучитьСтроку',
 					'СтрЧислоВхождений', 'СтрЧислоСтрок', 'Год', 'Year', 'День',