SSO Authentication for Citadel data causes app hang

Issue #239 wontfix
Sean Curry created an issue

When attempting to import data from on the Market Analysis tab the SSO Authentication window pops up and causes the application to hang. Running Evernus 1.52

This issue occurs on Windows 10 x64 and both elevated and non-elevated instances of Evernus. Left app running hung for 30 minutes to see if it would come back to life and it never did. Process needs to be killed.

Steps to that are used reproduce:

1) Start Evernus 2) Click Market Analysis tab 3) Click Import Data 4) Select Region (only The Forge) and select ALL market items and click OK.

Window pops up that is blank: "SSO Authentication for Character: <Character Name> (Not Responding)"

Application hangs after that.

Comments (17)

  1. Sean Curry reporter

    Should also add, quite sure it is for Citadel data because in 1.50 when Citadel data wasn't getting loaded the Market Analysis tab functioned normally when importing data. In 1.52 when first trying to import data a popup came up and said something similar to "SSO authentication is needed for importing Citadel data, press OK and sign in on next window".

  2. Kamil Rojewski repo owner

    Technically - it doesn't hang, but it's fetching an awful amounts of data in the background and it simply becomes almost unresponsive. Try running it with a small list of items for testing and see if it responds then.

  3. Sean Curry reporter

    Actually, it seems to be a collision with the Intel Reporter app that I run that also uses SSO. Interesting. The last time Everneus hung and was force closed, the intel reporter also crashed. I tried to repeat above steps and SSO authentication immediately came up and loaded so I could log in.

  4. Sean Curry reporter

    So, issue still seems to exist, even without intel app running and only very few market items selected. It's very random, I was only able to get the SSO auth window to fully load once.

  5. Kamil Rojewski repo owner

    Would you be interested in a debug build with the console visible? We could see if there's something running in the background.

  6. Sean Curry reporter

    Yes, certainly. Market Analysis has proven useful for me and I'd like for it to work again. :)

  7. Sean Curry reporter

    Here's where it hangs:

    No refresh token - requesting access. Qt WebEngine ICU data not found at F:/Qt/5.8/msvc2015_64/resources. Trying parent directory... Qt WebEngine ICU data not found at F:/Qt/5.8/msvc2015_64. Trying application directory... Installed Qt WebEngine locales directory not found at location F:/Qt/5.8/msvc2015_64/translations\qtwebengine_locales. Trying application directory... Qt WebEngine resources not found at F:/Qt/5.8/msvc2015_64/resources. Trying parent directory... Qt WebEngine resources not found at F:/Qt/5.8/msvc2015_64. Trying application directory...

    I have no idea what directory that is, I don't have an F: volume.

  8. Sean Curry reporter

    App doesn't launch, crashes immediately with error code 0xc000007b.

    "The application was unable to start correctly (0xc000007b). Click OK to close the application."

  9. Kamil Rojewski repo owner

    It seems I need to send you the whole package, instead of this one file. Will do it later.

  10. Sean Curry reporter

    Errors are gone in the console but it still hangs here: No refresh token - requesting access.

    I even tried a few other regions that have significantly less Citadels and the same issue occurs...

  11. Log in to comment