An ability to define a name of the original bean in @ReplaceWithMock and @WrapWithSpy
It could be useful to have an optional property name ("beanName"?) in @ReplaceWithMock and @WrapWithSpy to determine a name of a bean which should be replaces/wrapped. This would allow to use other field names (e.g. fooMock, barSpy). By default (the property is not set) a field name should be used (to be backward compatible).