Unexpected behaviour from config file

Issue #11 resolved
Kevin Kovalchik
created an issue

I am working on integrating Identipy into a quality control application and I have been having some issues working with the config file. Specifically, the decoy database option and the parameter optimization do not seem to be activated/changed by the contents of the config file. The first was easy to work around with command line arguments, but the second not so.

Including the following in the config file did not cause a decoy database to be created and used:

[input]
add decoy: yes
decoy method: reverse
prefix: DECOY_

The config file was provided to Identipy using the -cfg argument, but did not seem to change how the search ran. There were no decoy hits in the pepXML output. However, adding the appropriate arguments to the command line (i.e. -ad, -method, -prefix) did work.

Search parameter optimization

I would also like to include the following in the config file:

[misc]
first stage: identipy.extras.optimization

but again, this did not seem to change the search. The pepXML output is identical whether or not this is included in the config file. Even if it is changed in the default config file there is no change. In this case, I don't see a way to invoke the optimization from the command line. Is identipy.extras.optimization the default even when it is not specified in the config file?

I am calling Identipy from inside a .NET application, and in order to avoid some of the python warnings from popping up I am calling > python -W ignore [path to identipy-script.py] [arguments] instead of the Identipy exe directly.

Comments (7)

  1. Lev Levitsky repo owner

    Hi!

    First question: have you tried running IdentiPy directly to see if the problem appears this way? The problem may be related to the way you are calling it, if IdentiPy cannot locate its configuration correctly.

    Side note: you can invoke auto-optimization via command line using -at.

  2. Kevin Kovalchik reporter

    Hello,

    I tried running it directly and the same thing is happening. From the console output it looks like it is finding the default and the custom config file okay:

    console_out.PNG

    Good to know I can invoke the auto-optimization from the command line! I see it in the help now. I was looking at the arguments listed in the readme, but I guess they are a little out-of-date.

  3. Kevin Kovalchik reporter

    The configuration file seems to be used correctly now, thanks. However, I am running into a problem in the optimization now and I don't know if it is a bug or if I have set something up incorrectly. It runs through the first stage, but then there is a warning that there are 0 PSMs with 1% FDR and the optimization is aborted:

    Capture.PNG

    I have tried with a few different raw files and this has happened for all of them.

  4. Log in to comment