Commits

Mike Frysinger committed bdd6385

call AM_PROG_AR with newer automake

With recent versions of automake, it wants you to use this macro:

automake-1.13: warnings are treated as errors
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libgd.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:12: while processing Libtool library 'libgd.la'
autoreconf-2.68: automake failed with exit status: 1

  • Participants
  • Parent commits 68d2f1c

Comments (0)

Files changed (1)

 AC_MSG_RESULT([$os_cygwin])
 AC_SUBST([XTRA_LDFLAGS])
 
+dnl newer automake wants this, but we still want to work with older
+m4_ifndef([AM_PROG_AR],[m4_define([AM_PROG_AR],[:])])
+AM_PROG_AR
+
 AC_PROG_CC
 AC_PROG_INSTALL
 AC_PROG_LIBTOOL