Commits

pajoye  committed d2d6bc0

- project name and cmake required version must be set before calling
cpack

  • Participants
  • Parent commits 02cc792

Comments (0)

Files changed (1)

File CMakeLists.txt

 
+CMAKE_MINIMUM_REQUIRED(VERSION 2.4.3 FATAL_ERROR)
+PROJECT(GD)
 SET(CPACK_PACKAGE_NAME "libgd")
 SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "libGD, powerful and easy to use graphic library")
 SET(CPACK_PACKAGE_VENDOR "http://www.libgd.org")
 "^${PROJECT_SOURCE_DIR}/bld/"
 )
 INCLUDE(CPack)
-
-CMAKE_MINIMUM_REQUIRED(VERSION 2.4.3 FATAL_ERROR)
-PROJECT(GD)
-
 SET(CMAKE_MODULE_PATH "${GD_SOURCE_DIR}/cmake/modules")
 
 if (BUILD_TEST)