Issues

Issue #87 new

bug in glib-config?

Anonymous created an issue

In the case statement, for --ldflags, it looks to me like it should say "echo -L${prefix}/lib", rather than just "echo"

The problem shows up when you're building gnuplot-4.6.3. Here's a snippet of the gnuplot config.log (run through 'nl'):

2449 configure:9876: checking for gdImageCreateTrueColor in -lgd 2450 configure:9901: gcc -o conftest -g -O2 -I/usr/local/packages/libgd-2.1.0/installed/include conftest.c -lgd -lm >& 5 2451 /usr/bin/ld: cannot find -lgd

This happens even if you have configured using '--with-gd=...' (Your LD_LIBRARY_PATH variable is not relevant.) The gnuplot config then concludes that your libgd is too old, and therefore gnuplot decides it doesn't support jpeg terminals. Changing gdlib-config fixes this.

Comments (0)

  1. Log in to comment