1. Martin von Löwis
  2. pep381client
Issue #25 new

xml.parsers.expat.ExpatError: no element found: line 1, column 0

Anonymous created an issue

When trying to run on an existing mirror, I'm getting this backtrace. Please note this has been an issue for few weeks.

# /usr/bin/pep381run /srv/mirror/python/
Traceback (most recent call last):
  File "/usr/bin/pep381run", line 30, in <module>
    state.synchronize()
  File "/usr/lib/python2.6/site-packages/pep381client/__init__.py", line 119, in synchronize
    self._synchronize()
  File "/usr/lib/python2.6/site-packages/pep381client/__init__.py", line 129, in _synchronize
    changes = xmlrpc().changelog(self.last_completed-1)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1390, in _parse_response
    p.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 604, in close
    self._parser.Parse("", 1) # end of data
xml.parsers.expat.ExpatError: no element found: line 1, column 0

I've found a similar issue saying this is because of a package name corruption on the server side, but I don't think this is the case here. Syncing a new repository works. I saved the old one for troubleshooting.

Thank you,

Marek

Comments (0)

  1. Log in to comment