Commits

Sylvain Thénault committed 97d944e

prepare 0.21

  • Participants
  • Parent commits e2cb8cc
  • Tags pylint-version-0.21.0

Comments (0)

Files changed (4)

 ====================
 
  --
-
+   * command line updated (closes #9774, #9787, #9992, #22962):
+     * all enable-* / disable-* options have been merged into --enable / --disable
+     * BACKWARD INCOMPATIBLE CHANGE: short name of --errors-only becomes -E, -e being
+       affected to --enable
+     * pylint --help output much simplified, with --long-help available to get the
+       complete one
+   * revisited gui, thanks to students from Toronto university (they are great
+     contributors to this release!)
    * fix #21591: html reporter produces no output if reports is set to 'no'
    * fix #4581: not Missing docstring (C0111) warning if a method is overridden
    * fix #4683: Non-ASCII characters count double if utf8 encode
    * fix #9018: when using defining-attr-method, method order matters
    * fix #4595: Comma not followed by a space should not occurs on trailing comma 
      in list/tuple/dict definition
-
+   * fix #22585: [Patch] fix man warnings for pyreverse.1 manpage
+   * fix #20067: AttributeError: 'NoneType' object has no attribute 'name' with with
 
 2010-03-01  --  0.20.0
     * fix #19498: fix windows batch file
 
 modname = distname = 'pylint'
 
-numversion = (0, 20, 0)
+numversion = (0, 21, 0)
 version = '.'.join([str(num) for num in numversion])
 
 
-install_requires = ['logilab-common >= 0.49.0', 'logilab-astng >= 0.20.0']
+install_requires = ['logilab-common >= 0.50.1', 'logilab-astng >= 0.20.1']
 
 pyversions = ["2.3", "2.4", "2.5", '2.6'] # maybe 2.2 as well
 
+pylint (0.21.0-1) unstable; urgency=low
+
+  * new upstream release
+
+ -- Sylvain Thénault <sylvain.thenault@logilab.fr>  Tue, 11 May 2010 12:27:09 +0200
+
 pylint (0.20.0-1) unstable; urgency=low
 
   * new upstream release
 
 Package: pylint
 Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.49.0), python-logilab-astng (>= 0.20.0)
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.50.1), python-logilab-astng (>= 0.20.1)
 Recommends: python-tk
 XB-Python-Version: ${python:Versions}
 Conflicts: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test