Clone wiki

Lucee / System requirements

System Requirements

The basic requirement for running Lucee is a servlet engine. So basically if a servlet engine is available for your system, Lucee will most probably run on it. It even runs on a RaspberryPi.

Of course there are different recommendations that go with the different operating systems. Here are general guidelines for each OS.

Microsoft Windows

Windows Server 2008 & R2 all editions
Windows Server 2008 all editions
Windows 7 all editions
Windows 8.1 all editions
Windows Server 2012 & R2 all editions
Windows 10 all editions

Linux

Red Hat Enterprise Linux all editions
SUSE Linux all editions
Ubuntu all editions
Oracle Enterprise Linux
Cent OS all editions

Mac OS

Mac OS X all editions

Solaris

Solaris all editions

Hardware requirements for all operating systems

Minimum

256MB of RAM for the JVM
1 GB hard-disk space

Recommended

1GB of RAM for the JVM
10 GB hard-disk space

Updated