Overview

1. Dependencies

In ordred to install CCdeep you will need CMake (http://www.cmake.org) version 
2.6+ and bamtools (https://github.com/pezmaster31/bamtools).

2. Installation

In ccdeep directory create a build subdirectory and issue cmake there:

$ mkdir build
$ cd build
$ cmake ..

If cmake configuration goes without errors just issue

$ make
# make install

3. Possible errors

Bamtools library is typically installed under /usr/local/lib/bamtools. If that 
is not in your linker search path, you may need to issue

# /sbin/ldconfig /usr/local/lib/bamtools

or, on OS X

# install_name_tool -id /usr/local/lib/bamtools/libbamtools.X.X.X.dylib \
 /usr/local/lib/bamtools/libbamtools.X.X.X.dylib
 
where X.X.X is bamtools version (2.1.0 at time of writing)