Issue #185 resolved

Repeat replacement doesn't work in “other” view of split buffer

Christoph Lange
created an issue

How to reproduce: 1. suppose the current file is the only visible buffer (otherwise ensure with ^Wo) 2. split the buffer (^Ws) 3. in the new view move the cursor to a different position 3. replace the current character by "x" (rx) 4. switch to the other view (^W^W) 5. repeat the change (.) The change is applied in the same position where it was applied before (i.e. in the view that is now the “other” one), but not in the place where the cursor is now.

I tried it with deletion (d) as well, and there it worked.

Comments (4)

  1. Frank Fischer repo owner

    Hm, I've just tried but could not reproduce the problem, maybe I'm doing something wrong. Could you please give a detailed key-sequence (starting from make emacs or make term) that demonstrates the problem?

  2. Christoph Lange reporter

    I have now tried this with the latest version (in normal use, without make emacs) and couldn't reproduce it. So either it has never been a bug, or it has been fixed meanwhile. Thanks!

  3. Log in to comment