Some entity names missing in explanation

Create issue
Issue #7 on hold
Guilherme Passos created an issue

I am not sure if this is issue with BUNDLE or with owlexp, but some entities are missing in the explanation.

For instance, in some RDF files I have, I have names such as: <http://www.example.org/184-4> <http://www.example.org/184-1.edge>

However, the explanation becomes like this:

Explanation(s): 
1)   isTargetOf equivalentTo inverse hasTarget
     conj subClassOf DependencyRelation
     edge hasSource 
     isTargetOf some flat subClassOf not isSourceOf some DependencyRelation
     isSourceOf equivalentTo inverse hasSource
     edge type conj
     name subClassOf flat
     edge type name
     edge hasTarget 

That is, names beginning with numbers and dash have such characters removed (so 123-4.edge becomes simply edge and 123-4 becomes an empty string).

I have attached an example file. I have run it as:

/bundle/bundle --verbose --maxExplanations 1 --noProb -r hermit --method owlexp --inconsistent file://$FILE \
           1>$OUTDIR/$SIMPLE_NAME.out \
           2>$OUTDIR/$SIMPLE_NAME.err

Thanks!

Comments (7)

  1. Riccardo Zese

    From what I can see, this could be a bug of the class that convert axioms to Manchester syntax, which is used to print the explanations. However, we have to run your example and see. Just to know, have you tried different methods/reasoners? In the next days we will check.

  2. Guilherme Passos reporter

    Thank you. Yes, I have tried every possible (and valid) reasoner/explanation method, resulting in the same problem.

  3. Giuseppe Cota

    Unfortunately, it is a problem with the OWLAPI library and its conversion methods in Manchester syntax. I will move into two directions:

    1. Fix the conversion into Manchester syntax
    2. Set an option that allows to print the explanations with the full IRIs

    However, @GPPassos, if you need the set of explanations and manipulate them I would suggest to use BUNDLE as a library. If you need help for that I would be glad to make a Skype call.

  4. Log in to comment