Pull requests

#1 Open
Repository
navinumdevteam navinumdevteam
Branch
master
Repository
mailchimp mailchimp
Branch
master

Dependency management and .gitignore

Bitbucket cannot automatically merge this request due to conflicts.

Review the conflicts on the Overview tab. You can then either decline the request or merge it manually on your local system using the following commands:

git checkout master
git remote add navinumdevteam/mandrill-api-python https://bitbucket.org/navinumdevteam/mandrill-api-python.git
git fetch navinumdevteam/mandrill-api-python
git merge --no-ff -m 'Merged in navinumdevteam/mandrill-api-python (pull request #1)' remotes/navinumdevteam/mandrill-api-python/master
Author
  1. waawal
Reviewers
Description

Hi, Instead of having docopt pinned down to the version of 0.4.0 I changed the dependency to require docopt >= 0.4.0. We had some issues with other libraries that we use because of this outdated version in the requirements of mandrill.

This pull request also includes the addition of a .gitignore file and some cleanup of *.pyc-files.

Thanks for considering this.

Kind regards, Daniel Waardal

Comments (1)

  1. aguirrel

    I agree with waawal about docopt version, please, may you merge this to the latest version. Everytime I use it I get:

    pkg_resources.VersionConflict: (docopt 0.6.2 (/home/aguirrel/proyectos/blitzscript/env/lib/python3.3/site-packages), Requirement.parse('docopt==0.4.0'))

    Warning.

    Thanks a lot!

    Best regards,

    Luis Aguirre