Build with CUDA TK 7.5 fails

Create issue
Issue #3 on hold
italic_ created an issue

I'm trying to build in anticipation of Blender's GSOC project and couldn't build with CUDA support. Building without gave me no problems.

Commit: 4b21684e97d0f7cf3da10f2ec251e358d346fef8 (master as of this report) Options: OMP, Double Precision, GUI, CUDA

Cuda TK 7.5 Centos 7 x64

Attached is a log. I get the same error for meshtools.cu at line 163 and bouyancy.cu at line 124, although I only get both errors if I do a threaded build. I'm not a C programmer, so I couldn't fix this myself. I have not tried with TK 7 or 6.5 as those are enormous downloads.

Comments (5)

  1. thunil

    Hi italic_ , thanks for letting us know, but unfortunately, the CUDA version isn't really maintained at the moment. I can recommend using the CPU version for now, I hope we can get back to CUDA at some point, but right now things like the Blender integration itself is a higher priority.

  2. italic_ reporter

    Hey thunil. I totally understand. I hope one day blender will be able to utilize the GPU as an option, much like Cycles and OSD do. Until that day, though, CPU is going to be easier, of course. I'm not a dev myself, but I'm excited to see how this integration works. Good luck on these projects!

  3. thunil

    Cool, yes - please help us test the Blender version if you have time (both the current smoke version, and the upcoming liquids). We're happy to get feedback!

  4. Log in to comment