New online World_Online_SRTM900.wcs doesn't deliver DEM data

Issue #320 closed
wthaemelt created an issue

The new link contained in Europe_Online_DEM25.vrt works as expected in difference to the one to World....wcs. I can see some data transfer over the net but no elevation data. Is there a restriction to some regions? I tried locations in Germany and Spain without success.

Might the logfile message with "VRT" point to a problem? I didn't use a VRT as described by Mitxel.

2018-03-20 13:30:20.967 [debug] VRT: try to open "D:/GPS/DEM/World_Online_SRTM900.wcs"

Comments (12)

  1. Mitxel m

    Hi all

    With newer versions of QMS, those that list the .wcs in the DEM panel, the .vrt file would not be necessary.

    There is something strange with this world .wcs : in QMS on linux it runs ok, but I have tried on windows (win10 in a VM) an it does not return any elevation info, however it seems that no error is reported in the log file:

    2018-03-19 22:09:38.242 [debug] VRT: try to open "G:/DEM/WCS-basic/WCS_WORLD-DEM900.vrt"

    2018-03-19 22:09:38.323 [debug] has overviews true

    2018-03-19 22:09:38.323 [debug] no data: 0 -10000

    2018-03-19 22:09:38.323 [debug] QPointF(-3.14167,1.57087) QPointF(3.14152,1.57087) QPointF(3.14152,-1.04712) QPointF(-3.14167,-1.04712)

    2018-03-19 22:09:38.323 [debug] FF QTransform(type=TxScale, 11=0.000145444 12=0 13=0 21=0 22=-0.000145444 23=0 31=-3.14167 32=1.57087 33=0.0174533)

    2018-03-19 22:09:38.323 [debug] RR QTransform(type=TxScale, 11=6875.49 12=0 13=0 21=0 22=-6875.49 23=0 31=21600.5 32=10800.5 33=1)

    2018-03-19 22:09:38.449 [debug] start thread "dem"

    2018-03-19 22:09:38.449 [debug] bufferScale QPointF(150,-150)

    2018-03-19 22:09:38.790 [debug] stop thread "dem" after 341 ms

    I wonder why this gdal wcs file runs ok on linux and not on win. This is a bit surprising because other wcs files are running ok on the same windows. I am missing something but I can not figure out it yet. I am checking it


    edited: I think that is related to SSL certificates

  2. wthaemelt reporter

    Copying the 3 files mentioned in the latest DocMapsTipsRasterDEM.md edit seems to be not enough - still no elevation data with latest QMS and Windows10. The 2 files libeay32.dll and ssleay32.dll have been in my QMS root folder before testing the elevations. Any hint how to get more information about the problem?

  3. wthaemelt reporter

    This discussion leads to one more problem: The SSL requirement is not covered by the default Windows QMS installation routine. Thus the link to world...wcs in the initial help page should get a hint that the link is not for Windows users unless they have done additional installation work.

  4. Mitxel m

    I will try to summarize:

    • All .wcs are handled by gdal WCS driver that requires libcurl

    • Europe_online DEM uses gdal vsicurl that requires libcurl too

    • The default windows QMS install comes without libcurl, but it can be added by the user following the workaround described in the wiki to add MBTiles and curl

    • Although this stuff is installed some .wcs an some remote files accessed with vsicurl could fail (this is just the case for World_Online_SRTM900.wcs that tries to get the data from https://webmap.ornl.gov )

    • The last one seems to be a known problem related to libcurl and gdal. As referenced here and here it seems that libcurl( or gdal?) can not locate curl-ca-bundle.crt and connection is refused.

  5. wthaemelt reporter

    Using the Process Monitor tool I can see that libcurl is called when running QMS. But I can't find in the monitor protocol something related to curl-ca-bundle.crt. Normally, I would expect a message of the form "File not found" or something similar in this protocol. The tool records all operations on files!

  6. wthaemelt reporter

    It really seems to be a SSL problem. Calling gdal_translate to get a TIF from WCS

    gdal_translate World_Online_SRTM900.wcs a.tif
    

    I get:

    Input file size is 43200, 18000
    0ERROR 1: SSL certificate problem: unable to get local issuer certificate
    

    Setting

    set CURL_CA_BUNDLE=d:\QtProjects\QMS\QMapShack\msvc_64\Files
    

    (in this path is the curl-ca-bundle.crt file) the result is slightly different but still something is missing

    gdal_translate World_Online_SRTM900.wcs a.tif
    Input file size is 43200, 18000
    0ERROR 1: error setting certificate verify locations:
      CAfile: d:\QtProjects\QMS\QMapShack\msvc_64\Files
      CApath: none
    

    Are there more environment variables to use, e.g. for suppressing certificate verification? Couldn't find any. curl has parameters for this, but curl is called from gdal.

  7. wthaemelt reporter

    Next step:

    change environment setting to

    set curl_ca_bundle=d:\QtProjects\QMS\QMapShack\msvc_64\Files\curl-ca-bundle.crt
    

    and get

     gdal_translate World_Online_SRTM900.wcs a.tif
     Input file size is 43200, 18000
     0ERROR 1: Connection to MapServer timed out. Service temporarily unavailable, please try again later.
    

    Now, the SSL certification problem seems to be solved, but I don't understand the immediate time-out (no visible wait).

  8. wthaemelt reporter

    Success: Even if gdal_translate has still some problem, QMS using the environment

    set curl_ca_bundle=d:\QtProjects\QMS\QMapShack\msvc_64\Files\curl-ca-bundle.crt
    

    now finds and shows elevations! Be patient! Loading data from the server may take a little moment where either elevation is not yet updated or still missing.

  9. kiozen

    I close the issue as all Windows quirks have been solved. I try to persuade Helmut to add better support for CURL and all that stuff.

  10. Log in to comment