TMS host not found - missing GUI info?

Issue #321 closed
wthaemelt created an issue

The file MTBMap-cz.tms is part of Emi's online map file package. When trying to use this file, the QMS logfile shows messages of the following form:

[debug] TMS: try to open "D:/GPS/Maps/MTBMap-cz.tms"
[debug] tms: +proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +wktext +no_defs
[debug] start thread "map"
[debug] bufferScale QPointF(700,-700)
[debug] stop thread "map" after 78 ms
[warning] QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
[warning] QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
[warning] QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
[debug] Request to "http://tile.mtbmap.cz/mtbmap_tiles/7/68/42.png" failed: "Host tile.mtbmap.cz konnte nicht gefunden werden" 

The tile counter is showing the number of requested tiles. The map is not displayed.

When calling "http://tile.mtbmap.cz/mtbmap_tiles/7/68/42.png" from the Internet browser, the required image is shown. Thus, in this direct call the server works as expected.

What could be the reason for the warning message in the logfile? Would it be reasonable to inform the user in the QMS GUI about a problem?

Comments (4)

  1. kiozen

    There is no other information available than the one in the log. And broken *.tms files are not subject to QMapShack issue tracking. Except those that are built-in.

    There is no better way to inform the user. If QMapShack would use a message box it would annoy the user with every single tile failed to load. This can have many reasons. From temporary quirks to missing tiles on the server (e.g. sea areas). Or some serious problem with the *.tms definition. As several maps can overlay and if one can not be loaded the one below is displayed a "failed to load" tile is no option, too.

  2. Mitxel m

    About the reason:
    It seems that http://tile.mtbmap.cz is redirecting to http://tile.mtbmap.cz:81

    When calling "http://tile.mtbmap.cz/mtbmap_tiles/7/68/42.png" you will see the tile, but if you take a look at the url in the browser you will notice that it becomes "http://tile.mtbmap.cz:81/..."

    If you edit the TMS text file to append :81 to http://tile.mtbmap.cz QMS will load the tiles now, but I don't know if this is a temporally behavior or for a long term.

  3. Log in to comment