1. Marcin Kuzminski
  2. RhodeCode

Issues

Issue #268 wontfix

Upgrading Rhodecode

semmelb
created an issue

Today I tried to upgrade from my Rhodecode version 1.1.8 to 1.2.1 following the instructions given by: http://packages.python.org/RhodeCode/upgrade.html?highlight=whoosh .

At first I have to admit, that there is no version check for mercurial and sqlalchemy, but I manually upgraded them to 1.9.3 and 0.7.2. respectively.

When I tried to upgrade the database using: //paster upgrade-db production.in// The conversion broke with: //sqlalchemy.exc.OperationalError: (OperationalError) no such column//. I have attached the logfile: rhodecode_upgrade-db.log which shows the complete output.

Trying to serve this broken setup gives an error too, of cause. Just for completeness I have added this logfile too. It is named: //rhodecode_serve.log//.

Kind regards.

Comments (2)

  1. Marcin Kuzminski repo owner

    In upgrade log i see table groups already exists error.(that table was introduced in 1.2 )

    sqlalchemy.exc.OperationalError: (OperationalError) no such column Can happen on old sqlite version. Make sure you have at least 3.7

  2. Log in to comment