Error 404 after login

Issue #527 resolved
Gustavo Chaves created an issue

Yesterday (2012-08-18) I upgraded RhodeCode 1.4.0b in order to verify the resolution of issue #525. It worked, i.e., RC no longer stalled after having been configured to disallow anonymous access.

Now, when I access it I'm presented with the login form, as you can see in the first of the three screenshots I'm attaching to this issue.

However, when I log in I'm presented with the 404 error page that you can see in the second screenshot.

If then I manually strip off the path from the URL (/r/_admin/%2Fr%2F) and press enter, I can get to RC's main page, as you can see in the third screenshot.

I tried to log in as different users but everyone faced the same problem.

I also tried to log in from a pristine browser, without any cookies, but the problem remained.

I've reenabled anonymous access for now.

Comments (5)

  1. Marcin Kuzminski repo owner

    Did you enable the proxy-prefix middleware ? It is required if you want to serve serve RhodeCode with a prefix in path

  2. Gustavo Chaves reporter

    Yes. I don't have access to the RhodeCode instance right now, but I configured it with the following directives:

    filter-with = proxy-prefix

    <...>

    [filter:proxy-prefix]

    use = egg:PasteDeploy#prefix

    prefix = /r

  3. Log in to comment