Issue #547 open

Can't log in after first successfull ldap login

Anonymous created an issue

Successfully installed Rhodecode on a new machine and set it to use ldap accounts. Now for a while (first tested account) it was all fine. Rhode picked up user name, email, 2nd name from Active Directory. Now when new user logs with ldap in account it is created, but after log out it wont authenticate this user anymore. rhodecode.log: 2012-08-30 17:03:09.839 INFO [rhodecode.lib.base] User: <AuthUser('|True')> accessed / 2012-08-30 17:03:09.839 INFO [rhodecode.lib.auth] user is authenticated and granted access to HomeController:before after logout: 2012-08-30 17:05:11.556 WARNI [rhodecode.model.forms] user failed to authenticate

The list of users show that this account is not an ldap account, even if the user logged in using ldap credentials. User email is then set to

Comments (6)

  1. evesath

    After messing around with few ldap settings, I ended up with this: INVALID_CREDENTIALS: {'info': '80090308: LdapErr: DSID-0C0903A9, comment: AcceptSecurityContext error, data 52e, v1db1', 'desc': 'Invalid credentials'} 2012-08-30 21:53:53.546 WARNI [rhodecode.model.forms] user test.upr failed to authenticate

    Now all my ldap settings seems fine (they were working for a while at the very start). However obvious the error seems, the username and password is definetly correct. I do have connection to LDAP host, and the user credentials, DN base and login attribute are set correct... yet it refuses to log ldap user.

  2. Gilles Bouthenot

    Maybe you have setup your admin user with the same email address than the one you use with ldap ? Rhodecode can not have two users sharing a single email address. Try to change the email address of your admin user.

  3. Log in to comment