(Debian) Unable to install rhodecode due to depenendcy conflict webob>=1.2 and webob==1.0.8 at the same time

Issue #776 resolved
valentijnscholten created an issue

Hello,

When I follow the installation instructions, I am getting an error on:

paster make-config RhodeCode production.ini

Error:

pkg_resources.VersionConflict: (WebOb 1.0.8 (/home/git/rhodecode/venv/lib/python2.7/site-packages), Requirement.parse('WebOb>=1.2'))

To resolve this I upgraded WebOb to newest:

Downloading WebOb-1.2.3.tar.gz (191kB): 191kB downloaded

When I try to run paster make-config RhodeCode production.ini again, I am now getting the error that webob should be 1.0.8, contradicting the other error.

Complete trace: (venv)git@git:~/rhodecode/data$ paster make-config RhodeCode production.ini Distribution already installed: RhodeCode 1.5.3 from /home/git/rhodecode/venv/lib/python2.7/site-packages Traceback (most recent call last): File "/home/git/rhodecode/venv/bin/paster", line 8, in <module> load_entry_point('PasteScript==1.7.5', 'console_scripts', 'paster')() File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/paste/script/command.py", line 104, in run invoke(command, command_name, options, args[1:]) File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/paste/script/command.py", line 143, in invoke exit_code = runner.run(args) File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/paste/script/appinstall.py", line 68, in run return super(AbstractInstallCommand, self).run(new_args) File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/paste/script/command.py", line 238, in run result = self.command() File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/paste/script/appinstall.py", line 295, in command self.distro, self.options.ep_group, self.options.ep_name) File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/paste/script/appinstall.py", line 234, in get_installer 'paste.app_install', ep_name) File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 2221, in load_entry_point File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 1953, in load File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 1966, in require File "/home/git/rhodecode/venv/local/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 569, in resolve pkg_resources.VersionConflict: (WebOb 1.0.8 (/home/git/rhodecode/venv/lib/python2.7/site-packages), Requirement.parse('WebOb>=1.2'))

Comments (7)

  1. valentijnscholten reporter

    For now I changed the RhodeCode dependency to >=1.0.8 instead of ==1.0.8 Is this safe to do?

  2. valentijnscholten reporter

    If you have already installed, for now you can edit require.txt in the rhodecode-1.5.3 egginfo dir. You should add a line webtest==1.4.3. After that make sture you install the needed versions pip install WebTest==1.4.3 pip install WebOb==1.0.8

  3. Former user Account Deleted

    that worked, thank you very much mayby a little of topic ;) but how can i run the serve script and keep it runnig when my putty terminal is closed?

  4. Log in to comment