Allow configuration of the location of the git executable

Issue #780 resolved
Keith Gaughan created an issue

In a recent update of RhodeCode, it became dependent on the installed version of the git being at least 1.7.4. However, not all distros are up to even that. Debian Squeeze is on git 1.7.2.5.

To be able to work around this, it would be good to have the option to explicitly indicate the git executable RhodeCode should use. If none is specified, it would use the default system git, if a full path to the git executable was used (say '/opt/git/bin/git'), it could use that instead.

Comments (2)

  1. Log in to comment