Impossible to get name on [/dev/tty.usbmodem1461]</color>. Closing.

Create issue
Issue #18 new
Kiers created an issue
  • I am on ios High Sierra (10.13.6), running Unity 2018.1.6f1 and with an Arduino Mega 2560.
  • Unity player Api settings are .NET Standard 2.0 as required (attached player_settings png shows entire settings panel).
  • I have not been able to make Uduino work yet.
  • I have tried plugging the Arduino board into all of my USB sockets but none of them work.
  • Normal Arduino projects work fine and the Uduino sketch is uploaded on the Arduino.
  • When I click to "discover ports", the onboard micro LED on the Arduino board flashes, but then Uduino returns this error Impossible to get name on [/dev/tty.usbmodem1461]</color>. Closing.

Please help!

Comments (12)

  1. Marc Teys repo owner

    Hi,

    I'll have a look at this issue. Can you tell me if the issue is persistent when you change thoses settings (under Uduino script >Advanced) - Increase readTimeout to 50 - Increase writeTimeout to 50 - Select arduino MEGA as main board - Increase Discovery tries from 8 to 15

  2. Jeremy Ledbetter

    I'm running into the same issue. I'm running High Sierra 10.13.4, running Unity 2018.2.2f1 and using the current version of Uduino (2.1.6). I cannot get Unity to recognize the Mega I'm using. I've tried increasing the time outs, increased discovery tries and specified the main board type. I'm getting the "Impossible to get name on [serial port path]" debug message.

    I have an UNO board running the same sketch; when I plug it in instead, it detects just fine.

  3. Marc Teys repo owner

    I will have access to a Mac this Thursday, so i'll have a look. Was it working with previous versions of Uduino ?

  4. Kiers reporter

    I've followed all your recommendations and nothing has improved - it does exactly the same as I described in my first message. Also, I've updated to 2.1.6 which hasn't helped solve this problem (BTW it tells me I need to update to 2.1.5 although I have 2.1.6)

  5. Jeremy Ledbetter

    Hey Marc,

    I was able to test the mega connection on my PC. I can confirm that it connects as expected through the editor and in standalone builds.

  6. Marc Teys repo owner

    Hey,

    I just pushed a version with a fix on the Asset store (version 2.1.7). It might take few hours to be online..

    When we open a serial port, it reset the Arduino board. Usually, the program is launched really quickly, however on the Arduino mega it takes some time (around 1second). The problem is that when we open the serial port and write something while the program is not fully launched (in the 1s interval), it breaks any program present on the board. I couldn't find any information online about this issue, but other libraries for Arduino communication (eg. communication in JS) usually waits for 750ms / 1ms. I implemented this behavior in the latest version of Uduino; everything seems to work fine now. You can change the "discover delay" in the settings. If 750ms is not enough, try to increase the value.

    Capture.PNG

  7. Jeremy Ledbetter

    Brilliant, thanks Marc. I also appreciate the insight on how the Mega functions in relation to serial communication.

  8. Daniel Termin

    Hi! Having the same problem on OS X High Sierra 10.13.6 and Arduino Leonardo. Changing the above settings did not make it work. Suggestions? Also: Under Advanced -> Update Uduino, it says "Arduino library not present".

  9. Marc Teys repo owner

    Hi Daniel,

    Have to tried to increase the Discover delay to 1 or 1.5 ? It might help. The message saying "Arduino library not present" is normal, it's meaning that you probably correclty added the Uduino library to your Arduino/ folder. I should change the name of this message though.

  10. Daniel Termin

    Thanks for the quick reply! Yes, I've tried increasing the Discover delay to 1 and 1.5, but still getting:

    #!c#
    
    Impossible to get name on [/dev/tty.usbmodem1421]. Closing.
    

    I don't know what to do? Uploading and running programs from the Arduino app works fine and I've successfully managed to run programs via the Javascript-based Johnny-Five library so I know that the connection is working.

    Please advice. Kind Regards, Daniel

  11. Daniel Termin

    What does the warning mean? Could I find something in the code that could help me? If it doesn't work, is it possible to get a refund for the plugin?

    I really would like to get it working though :)

  12. Marc Teys repo owner

    It's meaning that is successfully access the board, but can't get the "identity" of the board. Normally, you should see the Rx/Tx LEDs blinking on the board after pressing play. Can you try the following :

    Re-upload the code on the Arduino Leonardo
    
    Increase the read and write timeout ( Advanced > General Serial Settings > Read/Write timeout)
    
    Augment the number of discovery tries (Advanced > Discovery settings )
    
  13. Log in to comment