Commits

Pierre-Yves David committed 68e3d6e

evolve: drop `latercomer` and `conflicting` compatibility.

Those old alias are deprecated for a long time now. All computations related to
troubles are in Mercurial core for multiple versions.

Comments (0)

Files changed (2)

 
 3.3.0 --
 
+- drop `latercomer` and `conflicting` compatibility. Those old alias are
+  deprecated for a long time now.
 - added Augie Facklers `fastop` extension (usage not recommended yet)
 - add verbose hint about how to handle corner case by hand.
   This should help people until evolve is able to to it itself.
 getrevs = obsolete.getrevs
 
 #####################################################################
-### Complete troubles computation logic                           ###
-#####################################################################
-
-
-### changectx method
-
-@eh.addattr(context.changectx, 'latecomer')
-def latecomer(ctx):
-    """is the changeset bumped (Try to succeed to public change)"""
-    return ctx.bumped()
-
-@eh.addattr(context.changectx, 'conflicting')
-def conflicting(ctx):
-    """is the changeset divergent (Try to succeed to public change)"""
-    return ctx.divergent()
-
-### revset symbol
-
-eh.revset('latecomer')(revset.symbols['bumped'])
-eh.revset('conflicting')(revset.symbols['divergent'])
-
-
-
-
-#####################################################################
 ### Additional Utilities                                          ###
 #####################################################################