Martin von Löwis  committed 590a98a

Discourage using GCC 4.2 for Python.

  • Participants
  • Parent commits d43d942
  • Branches 2.5

Comments (0)

Files changed (1)

 submit a documentation bug report to SourceForge (see Bug Reports
 above) so we can remove them!)
+GCC 4.2: There is a known incompatibility between Python and GCC,
+         where GCC 4.2 takes an interpretation of C different from
+	 prior GCC releases, in an area where C has undefined behaviour
+	 (namely, integer arithmetic involving -sys.maxint-1).
+	 As a consequence, compiling Python with GCC 4.2 is not
+	 recommend. It is likely that this problem will be resolved
+	 in future Python releases.
 Unix platforms: If your vendor still ships (and you still use) Berkeley DB
         1.85 you will need to edit Modules/Setup to build the bsddb185
         module and add a line to which makes it the